This project is read-only.

how to register TagPrefix on web.config

Sep 15, 2009 at 6:47 AM

Quote from your documentation

This project use Ajax, so please edit your web.config
In order to user the user control, please add these two lines of code :

<%@Register TagPrefix="WIO" Assembly="WhoIsOnline, Version=1.0.0.0, Culture=neutral, PublicKeyToken=4e7c025c74beae84" namespace="WhoIsOnline.WhoIsOnlineControl" %>
<WIO:WhoIsOnlineControl RefreshTime="1" RefreshUnit="m" />

got stuck when trying to insert above code inside web.config

 

Sep 15, 2009 at 7:50 AM
Edited Sep 15, 2009 at 7:52 AM

Hello,

actually, it is not in the web.config file that you have to insert these two lines of code but in the master page where you want to use the User Control ?

Regards

Sep 15, 2009 at 8:05 AM

Tq for reply

after add to masterpage, i got new error,

unable to add selected webpart. this is not registered as safe..

Sep 15, 2009 at 8:09 AM

Hello,

have you well installed and activated the feature in the site (or web) feature ? Normally, when you activate my feature, the corresponding line are automatically added to the web.config file and then you'll be able to use the webpart/user Control.

Sep 15, 2009 at 8:38 AM
Edited Sep 16, 2009 at 1:32 AM

got the new error after re-activate the future in central admin & site action

Unable to add selected web part

Who is online?:could not load file or assembly

'Microsoft.Office.Server, Version.......

PublicKeyToken=71e... or one of its dependencies. The

system cannot find the file specified.

 --------------------------------------------------------------

when i checked,  i see the different between publicKeyToken in pop-up error (71e9bce111e9429c) and your code (4e7c025c74beae84)

is it caused the problem?

 

Sep 28, 2009 at 4:37 PM

Hello,

Do you have WSS or MOSS ? I think that the DLL that couldn't be retrieve is Microsoft.Office.Server and its delivered with MOSS 2007 but not with WSS. My feature works only on MOSS 2007.

Oct 1, 2009 at 4:34 AM

ooo..

that why not work on me...

can you recompile it in WSS?

TQ

Oct 1, 2009 at 6:22 AM

Hello,

no I can't. Indeed, this feature use profile informations only available on MOSS, so it won't work for WSS.

Sorry

May 7, 2010 at 4:31 PM

Are there any better instructions on where the resource files go?

Everything installs without error yet the webparts will not hold it's settings when  a user clicks on new message it goes back to alternate page or just shows you must configure the webparts.